Author Topic: FTL Restore Issues (Missing Pool Blocks)  (Read 1718 times)

Offline aaronboeingfan

  • Member
  • Posts: 1
  • Karma: +0/-0
    • View Profile
FTL Restore Issues (Missing Pool Blocks)
« on: October 30, 2010, 10:19:43 AM »
Hello everyone, I just want to start off by saying thanks to everyone that has helped this project. But, I have run into this issue that has been haunting my iPod 1G. When I boot, iOS boots fine, but when openiboot is started, it can't connect to my filesystem, I believe, because it says that an FTL restore failed and there are missing pool blocks. I have a backup of my NOR, I have restored it using the backup, no luck. I have restored it with 3.1.3, used redsn0w, no luck. I have restored with 3.1.2, used blackra1n, no luck. In all restores, I have used DFU mode to restore it. I have also used different versions of openiboot from the first to last, and all the same result. It all started when I had no choice but to hard reboot my iPod when Android froze because the screen when off, since I set it to after a while of no use, and it wouldn't respond to any button being pressed, or held. After that point, I haven't been able to use it again. I also have used linux and OS X for openiboot, put figured that wouldn't matter. This is an example of what happens...
Code: [Select]
sh-3.2# ./oibc
Client connected: !<filename>[@<address>] to send a file, ~<filename>[@<address>]:<len> to receive a file
---------------------------------------------------------------------------------------------------------
miu: epoch mismatch
PLL 1: off.
PLL 0: off.
PLL 1: 412000000
PLL 2: off.
PLL 3: 108000000
NOR vendor=bf, device=273f
syscfg: found version 0x00020001 with 6 entries using 144 of 8192 bytes
Successfully loaded bank1 nvram
Successfully loaded bank2 nvram
syrah_quiesce()
otf clock divisor: 5
fps set to: 59.976
SFN: 0x10300, Addr: 0xfd00000, Size: 0x14001e0, hspan: 0x280, QLEN: 0xa0
syrah_init() -- Hurray for displays
Syrah Panel ID (0xb3c21a):
   Build:          UNKNOWN
   Type:           TMD
   Project/Driver: N45/NSC-Muscat AutoBoot Enabled
Autoboot display...
turning on parity error flag
syrah_init success!
Installing gamma table 0x0000c210 / 0x0000ff70
menu: images loaded
USB state change: 0 -> 0
EP 0: 2
EP 1: 2
EP 2: 2
EP 3: 2
EP 4: 2
EP 5: 2
USB state change: 0 -> 1
sdio: selecting voltage index 23
sdio: cccr version: 0, sdio version: 0, low-speed: 0, high-speed: 0, wide bus: 1, multi-block: 1, functions: 1
sdio: turning off pull-up resistor on DAT[3]
Manufacturer ID: 0x2df, product ID: 0x9103
Function: 0, max block size: 256
Function: 1, max block size: 256, enable timeout: 1000 ms
sdio: Ready!
sdio: enabled function 1
wlan: ioport = 0x10000
wlan: firmware status = 0x0
nand: Probing flash controller...
usb: reset detected
USB state change: 1 -> 1
USB state change: 1 -> 3
USB state change: 3 -> 4
nand: DEVICE: a514d3ad
nand: BANKS_TOTAL: 8
nand: BLOCKS_PER_BANK: 4096
nand: SUBLKS_TOTAL: 4096
nand: USER_SUBLKS_TOTAL: 3872
nand: PAGES_PER_SUBLK: 1024
nand: PAGES_PER_BANK: 524288
nand: SECTORS_PER_PAGE: 4
nand: BYTES_PER_SPARE: 64
nand: BYTES_PER_PAGE: 2048
nand: PAGES_PER_BLOCK: 128
ftl: Found production format: 43303035
ftl: Successfully found FTL context block: 3
ftl: Possible unclean shutdown, last FTL metadata type written was 0x4f
ftl: FTL_Open cannot load FTLCxt!
ftl: restore searching for latest FTL context...
ftl: restore found useable FTL context with usnDec = 0xfffffd40
ftl: Detected version 46560001 b9a9fffe
ftl: restore scanning virtual blocks 0 - 999
ftl: restore scanning virtual blocks 1000 - 1999
ftl: restore scanning virtual blocks 2000 - 2999
ftl: restore scanning virtual blocks 3000 - 3894
ftl: restore creating mapping table...
ftl: restore scanning logical blocks 0 - 999
ftl: restore scanning logical blocks 1000 - 1999
ftl: restore scanning logical blocks 2000 - 2999
ftl: restore scanning logical blocks 3000 - 3871
ftl: restore determing free vbs...
ftl: restore wNumOfFreeVb = 7, number of log vbs = 14
ftl: restore failed, we are missing pool blocks!
ftl: FTL_Open failed
bdev: partition id: 0, type: af, sectors: 63 - 256063
bdev: partition id: 1, type: af, sectors: 256095 - 3964905
version: openiboot 0.1 commit b54f1ad for iPod touch 1G
-----------------------------------------------
              WELCOME TO OPENIBOOT
-----------------------------------------------


Offline KoMar

  • Member
  • Posts: 1
  • Karma: +0/-0
    • View Profile
  • iDevice: iPhone 2G
  • iDroid Version: 10.04
  • Jailbreak: redsn0w
Re: FTL Restore Issues (Missing Pool Blocks)
« Reply #1 on: September 30, 2012, 05:52:10 PM »
The only thing that worked for me was to execute "nand_erase 0 0", then "reboot".