Author Topic: Problem with zephyr2.bin - iDroid won't boot  (Read 1076 times)

Offline PolrBear

  • Member
  • Posts: 3
  • Karma: +0/-0
    • View Profile
  • iDevice: iPhone 3G, iOS 4.2.1
  • iDroid Version: 11.04
  • Jailbreak: redsn0w 0.9.6b4
Problem with zephyr2.bin - iDroid won't boot
« on: February 02, 2012, 03:05:59 PM »
When installing iDroid through Bootlace, I encountered exactly the same problem reported by users in this thread and this one: The installer would hang on "Resolving dependencies" with an error in the log indicating a problem extracting the Multitouch driver.  Like the OP in one of those threads, I tried tapping the "i" and extracting the driver manually, but that that only caused Bootlace to crash.  So, I SSH'd into the phone to see about placing zephyr2.bin where it needs to go manually, a strategy which the OP of the first thread above seems to have used with success.  I found zephyr2.bin already extracted under /root (by Bootlace I assume), and moved it to /private/var/firmware as per the Windows manual installation instructions.  I then restarted the iDroid installer, which proceeded to complete with no errors, and now shows the latest version installed.  However, when I try to boot into iDroid, the startup screen loops into a constantly repeated error that goes by so quickly I cannot read the whole thing.  I can see that the error starts with "zephyr2".  (I'm not sure if startup errors are logged somewhere?) 

I'm kind of at a loss to know where to go from here.  Any help would be appreciated.

Offline nickp666

  • Administrator
  • Member
  • *****
  • Posts: 682
  • Karma: +45/-0
    • View Profile
    • http://www.nickpack.com
  • iDevice: Various
  • iDroid Version: Latest
  • Jailbreak: Various
Re: Problem with zephyr2.bin - iDroid won't boot
« Reply #1 on: February 06, 2012, 08:27:31 PM »
There seems to be an issue with newer versions of redsn0w and the z2 firmware extraction process - re-jailbreak with an older redsn0w is your best bet (no restore needed, do it over the top)

Offline PolrBear

  • Member
  • Posts: 3
  • Karma: +0/-0
    • View Profile
  • iDevice: iPhone 3G, iOS 4.2.1
  • iDroid Version: 11.04
  • Jailbreak: redsn0w 0.9.6b4
Re: Problem with zephyr2.bin - iDroid won't boot
« Reply #2 on: February 07, 2012, 05:47:50 PM »
Thanks for the reply.  I re-jailbroke the phone with redsn0w 0.9.6b4, which I believe is the oldest version that supports by 4.2.1 firmware.  Unfortunately, I'm getting exactly the same results as before when trying to install iDroid (which I removed because it wasn't even trying to boot after the re-jailbreak).  Is there a next step you can suggest?

Offline PolrBear

  • Member
  • Posts: 3
  • Karma: +0/-0
    • View Profile
  • iDevice: iPhone 3G, iOS 4.2.1
  • iDroid Version: 11.04
  • Jailbreak: redsn0w 0.9.6b4
Re: Problem with zephyr2.bin - iDroid won't boot
« Reply #3 on: February 29, 2012, 08:21:29 PM »
Just to follow up, I did finally get iDroid to install and boot by manually extracting zephyr2.bin.

Once booted, it does have some pretty major functionality gaps such as being unable to access my WiFi.  Interesting experiment, but I think I may just pick up an actual Droid device for testing after all.

Anyway, thanks for the help.  :)