Author Topic: [SOLVED] Problem with Booting iphone, autoboots openiboot console  (Read 203 times)

Offline kirasin

  • Member
  • Posts: 5
  • Karma: +0/-0
    • View Profile
  • iDevice: Iphone 3G
  • iDroid Version: MoJo 1.0.3
  • Jailbreak: redsn0w 0.9.6b
hello there.

Just registered in hope of getting some help fixing my iphone.
I have openiboot 1.0.2 (i think) installed,using psfreedom.
Everything worked perfectly till a few days ago.
I updated bootlace to the newest version and noticed that quickbooting to android (which booted psfreedom) didnt work,it booted me to console instead,so i was just power+home resetting and picking android from the iboot menu.
Now here is what just happened....I tried quickbooting from bootlace to console instead, to test if it does actually boot to console or android (was curious since android booted me to console).
So,quickbooting to console did in fact boot me to console,but after that everytime i restarted the iphone it autoboots to console.
That really sucks -.- so here is what i already tried.

1) sudo ./oibc and printenv
opib-menu-timeout = 10000
opib-default-os = 0
opib-temp-os = 3
opib-version = 0.1.2
bootdelay = 0
backlight-level = 21
platform-uuid = ����#l��
opib-hide-menu = false
toInstall = 1
auto-boot = false
boot-args =

Im not sure if everything is correct,but hide menu is false and so is auto boot,so i guess there are no problems there?
either way i went and setenv opib-hide-menu false and same thing for autoboot. and then saveenv and reboot

didnt work. Still autobooting to console.

2)rechecked the printenv to see if it saved...or something...still looks the same as my paste above.

help appreciated,im pretty lost,i googled the problem and etc,gonna continue reading through this forum.

Pardon if i posted in the wrong place or if i didnt read/see something in the faq that could solve this =/
« Last Edit: December 06, 2010, 04:57:13 PM by ddominator »

Offline ddominator

  • The Dominator
  • Global Moderator
  • Member
  • *****
  • Posts: 957
  • Karma: +11/-0
  • Sold his soul to Google
    • View Profile
    • Unofficial iDroid News Blog
  • iDevice: iPhone 2G 3.1.3
  • iDroid Version: MoJo 1.0.4.1
  • Jailbreak: redsn0w 0.94 FTW!!!
Re: Problem with Booting iphone, autoboots openiboot console
« Reply #1 on: December 06, 2010, 04:15:41 PM »
Please say exactly what version of OpeniBoot you have... we haven't even reach 1.0 yet... the latest is 0.2

Also where are the files for PS Freedom located? In what folder?

If OpeniBoot cannot find the files, it will directly boot into console.

So if you are using OIB 0.1.2 and above, the files should be in /private/var/idroid  Using OIB 0.1.1 and below, files are in /private/var
Help Google takeover the world. Use Android on your mobile devices, use Chrome Browser, use Chrome OS!!!

Offline kirasin

  • Member
  • Posts: 5
  • Karma: +0/-0
    • View Profile
  • iDevice: Iphone 3G
  • iDroid Version: MoJo 1.0.3
  • Jailbreak: redsn0w 0.9.6b
Re: Problem with Booting iphone, autoboots openiboot console
« Reply #2 on: December 06, 2010, 04:21:04 PM »
ow damn,pardon me I misstyped it...

Openiboot version is 1.0.2
Using VM virtual box ubuntu 9.10

I just tried installing it again ,it installed successfully,printevn still shows false,still boots to console...
also...when installing it made a norbackup to the same folder,did i just overwrite my first norbackup? o.o if yes,am i screwed if my nor is...well,damaged?

As for the files,I cant check to tell you since i cant SSH into my phone while its in console mode (or can I?)
But im sure they are in the right folder,simply cause i didnt update openiboot,it was and is on 0.1.2,and psfreedom did boot.
my problem now is that my iphone is booting to console and doesnt let me pick between IOS console android and etc.
« Last Edit: December 06, 2010, 04:22:56 PM by kirasin »

Offline ddominator

  • The Dominator
  • Global Moderator
  • Member
  • *****
  • Posts: 957
  • Karma: +11/-0
  • Sold his soul to Google
    • View Profile
    • Unofficial iDroid News Blog
  • iDevice: iPhone 2G 3.1.3
  • iDroid Version: MoJo 1.0.4.1
  • Jailbreak: redsn0w 0.94 FTW!!!
Re: Problem with Booting iphone, autoboots openiboot console
« Reply #3 on: December 06, 2010, 04:36:45 PM »
Oops sorry... didn't get to read that iOS booted into console...

Hmm try changing your opib-default-os = 0 (which is nothing) to 1 (iOS)  More about it here http://www.idroidproject.org/wiki/OpeniBoot#Configuring  I'm not sure if that's the problem because your auto-boot is disabled.  Also change your opib-temp-os to 1 (iOS) from 3 (console)

You can use the "uninstall" command at any time if you want to give up to get iOS back (2nd to last resort... last resort is DFU).

Help Google takeover the world. Use Android on your mobile devices, use Chrome Browser, use Chrome OS!!!

Offline kirasin

  • Member
  • Posts: 5
  • Karma: +0/-0
    • View Profile
  • iDevice: Iphone 3G
  • iDroid Version: MoJo 1.0.3
  • Jailbreak: redsn0w 0.9.6b
Re: Problem with Booting iphone, autoboots openiboot console
« Reply #4 on: December 06, 2010, 04:40:11 PM »
Dfu is scary, hmm,gonna try what you suggested and check.
Still I don't get why it got stuck there, maybe i should post this on the bootlace support? since that was the cause.

Either way brb, going to try your suggestions, was thinking of doing the same thing.

Offline kirasin

  • Member
  • Posts: 5
  • Karma: +0/-0
    • View Profile
  • iDevice: Iphone 3G
  • iDroid Version: MoJo 1.0.3
  • Jailbreak: redsn0w 0.9.6b
Re: Problem with Booting iphone, autoboots openiboot console
« Reply #5 on: December 06, 2010, 04:47:28 PM »
Ok so, default to 1 didnt work so i put it back to 0

temp to 1 booted android(psfreedom) instead of ios

rebooted,VOILA! openiboot menu appeared and i can select console and etc again, problem is ios puts me into recovery mode,which is bad, im gonna try getting it out of recovery with a tool i have...somewhere.
Brb again.

Offline kirasin

  • Member
  • Posts: 5
  • Karma: +0/-0
    • View Profile
  • iDevice: Iphone 3G
  • iDroid Version: MoJo 1.0.3
  • Jailbreak: redsn0w 0.9.6b
Re: Problem with Booting iphone, autoboots openiboot console
« Reply #6 on: December 06, 2010, 04:53:39 PM »
Success, recovery fixed. Checking openiboot menu, still there.

Problem solved.

Well then :) thank you for your support and helping me fix my problem, I would have probably took much longer to solve this alone.

Have a good day and lemme know where the +button is >.< i cant give you karma...

UPDATE!: being lazy is bad :P and sorry for the triple post. :)
« Last Edit: December 06, 2010, 05:00:01 PM by kirasin »

Offline ddominator

  • The Dominator
  • Global Moderator
  • Member
  • *****
  • Posts: 957
  • Karma: +11/-0
  • Sold his soul to Google
    • View Profile
    • Unofficial iDroid News Blog
  • iDevice: iPhone 2G 3.1.3
  • iDroid Version: MoJo 1.0.4.1
  • Jailbreak: redsn0w 0.94 FTW!!!
Re: [SOLVED] Problem with Booting iphone, autoboots openiboot console
« Reply #7 on: December 06, 2010, 04:58:17 PM »
Good to hear...

No worries on the karma, I'm here to help.

And next time, don't triple post put UPDATE 1 2 3 or whatever... but I'm too lazy to merge all your posts.
Help Google takeover the world. Use Android on your mobile devices, use Chrome Browser, use Chrome OS!!!