Author Topic: Bootlace problem  (Read 283 times)

Offline knny1491

  • Member
  • Posts: 11
  • Karma: +0/-0
    • View Profile
  • iDevice: iphone 3g
  • iDroid Version: 0.2
  • Jailbreak: redsnow
Bootlace problem
« on: November 30, 2010, 07:45:50 PM »
Wow seems like Idroid just doesnt want me to have froyo, but I go to install open iboot and it says the kernel cache seems to be improperly patched please reinstall bootlace, do the same and nada. I DFU restored into this and rejailbroke and that didnt help. Any suggestions on how to get this working?

Offline ddominator

  • The Dominator
  • Global Moderator
  • Member
  • *****
  • Posts: 957
  • Karma: +11/-0
  • Sold his soul to Google
    • View Profile
    • Unofficial iDroid News Blog
  • iDevice: iPhone 2G 3.1.3
  • iDroid Version: MoJo 1.0.4.1
  • Jailbreak: redsn0w 0.94 FTW!!!
Re: Bootlace problem
« Reply #1 on: November 30, 2010, 09:12:56 PM »
What device, iOS, and jailbreak did you use?
Help Google takeover the world. Use Android on your mobile devices, use Chrome Browser, use Chrome OS!!!

Offline knny1491

  • Member
  • Posts: 11
  • Karma: +0/-0
    • View Profile
  • iDevice: iphone 3g
  • iDroid Version: 0.2
  • Jailbreak: redsnow
Re: Bootlace problem
« Reply #2 on: November 30, 2010, 10:57:38 PM »
I figured out the problem I rejailbroke the 4.1 with snowbreeze the first time, I DFU restored then jailbroke via redsnow and now I have it working, except NOW abd won't connect to my phone's IP address, god this is so tricky lol.

Offline ddominator

  • The Dominator
  • Global Moderator
  • Member
  • *****
  • Posts: 957
  • Karma: +11/-0
  • Sold his soul to Google
    • View Profile
    • Unofficial iDroid News Blog
  • iDevice: iPhone 2G 3.1.3
  • iDroid Version: MoJo 1.0.4.1
  • Jailbreak: redsn0w 0.94 FTW!!!
Re: Bootlace problem
« Reply #3 on: November 30, 2010, 11:06:02 PM »
Well ADB not connecting is no longer a problem of bootlace LOL.

But are you connected to your WiFi?
Help Google takeover the world. Use Android on your mobile devices, use Chrome Browser, use Chrome OS!!!

Offline knny1491

  • Member
  • Posts: 11
  • Karma: +0/-0
    • View Profile
  • iDevice: iphone 3g
  • iDroid Version: 0.2
  • Jailbreak: redsnow
Re: Bootlace problem
« Reply #4 on: November 30, 2010, 11:16:00 PM »
Yes I am connected, type in the following:

cd\
cd\androidsdk\tools
adb connect 192.168.1.102:5555

and i get the error "cannot connect to 192.168.1.102:5555:5555"

I have loads of previous experience with android(Owned a rooted mytouch for 2 years, only dont have it cuz I lost it lol) so I am more than familiar with adb and fastboot commands having rooted several Android devices yet this is stumping me lol.

Offline ddominator

  • The Dominator
  • Global Moderator
  • Member
  • *****
  • Posts: 957
  • Karma: +11/-0
  • Sold his soul to Google
    • View Profile
    • Unofficial iDroid News Blog
  • iDevice: iPhone 2G 3.1.3
  • iDroid Version: MoJo 1.0.4.1
  • Jailbreak: redsn0w 0.94 FTW!!!
Re: Bootlace problem
« Reply #5 on: November 30, 2010, 11:21:44 PM »
Odd... that it repeats the port twice...

Have you tried just connecting via ip address (192.168.1.100) minus the 5555 port? Android will by default connect to the 5555 port.
Help Google takeover the world. Use Android on your mobile devices, use Chrome Browser, use Chrome OS!!!

Offline knny1491

  • Member
  • Posts: 11
  • Karma: +0/-0
    • View Profile
  • iDevice: iphone 3g
  • iDroid Version: 0.2
  • Jailbreak: redsnow
Re: Bootlace problem
« Reply #6 on: November 30, 2010, 11:26:09 PM »
yes I did, and it says the same error without repeating the port, I am resetting my router(Thing is often very finicky) to see if that was the problem.

Offline knny1491

  • Member
  • Posts: 11
  • Karma: +0/-0
    • View Profile
  • iDevice: iphone 3g
  • iDroid Version: 0.2
  • Jailbreak: redsnow
Re: Bootlace problem
« Reply #7 on: November 30, 2010, 11:36:24 PM »
Alright router didnt fix the problem, I remember with my mytouch having to install ADB drivers for it, but with this I haven't dDL any ADB drivers, could that be the issue?

Offline RiceX1055

  • Member
  • Posts: 1
  • Karma: +0/-0
    • View Profile
  • iDevice: iPhone 3G
  • iDroid Version: 1.0.4.1
  • Jailbreak: redsn0w 0.9.6b6
Re: Bootlace problem
« Reply #8 on: December 06, 2010, 11:51:18 PM »
I had the same problem when I installed iDroid through bootlace on my phone earlier.

from a google search I found that I needed to configure the adb over wifi.

Code: [Select]
   
su

    setprop service.adb.tcp.port 5555

    stop adbd

    start adbd

That worked for me. Run it from terminal emulator on iDroid.

Source
http://stackoverflow.com/questions/2604727/how-can-i-connect-to-android-with-adb-over-tcp

RiceX1055