Author Topic: problems installing linux  (Read 705 times)

Offline vigilantez

  • Member
  • Posts: 8
  • Karma: +0/-0
    • View Profile
problems installing linux
« on: August 19, 2010, 09:46:58 PM »
hello well i have been looking forward for linux fo awhile but when i try to install i allways run into de same problems

Code: [Select]
unknown command: kernel

i have tried version ubuntu and xubuntu with same problem every thing else runs smothly untill i reach this command

any way to fix it ?

Offline Ninn

  • Administrator
  • Member
  • *****
  • Posts: 130
  • Karma: +65535/-1
    • View Profile
Re: problems installing linux
« Reply #1 on: August 19, 2010, 10:16:32 PM »
you must be failing somewhere within the howto, i.e. not have positioned kernel properly, try again and make sure you do it right:

Quote
How to:

1. Copy ix.img to /private/var on your iPhone when complete, cleanly poweroff your iPhone by holding power and sliding to poweroff.
2. Turn your phone back on, plug it in to your pc using USB and select console.
3. On your Linux install wether native or virtualised, open a terminal and cd to the dir in which initrd.img.gz zImage and oibc are stored.
4. gunzip initrd.img.gz, mount it, copy your multitouch and wifi firmware to /lib/firmware, unmount and rezip.
Example:
Code: [Select]
gunzip initrd.img.gz
mount -o loop initrd.img.gz /Path/to/mount
cp Firmwares /Path/to/mount/lib/firmware
umount /Path/to/mount
gzip initrd.img.gz
5. Run sudo ./oibc, you should hopefully see "Welcome to OpeniBoot"
6, Run the following commands, waiting for them to complete before continuing:
Code: [Select]
!zImage
kernel
!initrd.img.gz
ramdisk
boot "root=/dev/ram0 init=/init rw"
7. You will eventually see an xfce desktop, this is chosen simply because it's more lightweight than Gnome, feel free experiment with any window manager or desktop enviroment you want.

Offline jfitzkappes

  • Member
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: problems installing linux
« Reply #2 on: August 19, 2010, 10:26:29 PM »
Quote from: "vigilantez"
hello well i have been looking forward for linux fo awhile but when i try to install i allways run into de same problems

Code: [Select]
unknown command: kernel

i have tried version ubuntu and xubuntu with same problem every thing else runs smothly untill i reach this command

any way to fix it ?

A couple questions:
1. are you working with the most recent iX project release (iX-UbuntuDevImageV0.01.rar from http://idroid.nickpack.com/iX/)?
2. Are you following the "READMEFIRST" file included with the iX package?
3. did you know that the READMEFIRST file has an error in it?  The example given in step four should be this:
Code: [Select]
gunzip initrd.img.gz
mount -o loop initrd.img /Path/to/mount
cp Firmwares /Path/to/mount/lib/firmware
umount /Path/to/mount
gzip initrd.img

Good luck, let us know how it goes!
[size=85]- iPhone 3G [unlocked, on T-Mobile], iOS3.1.2, iDroid 1.0 Mojo, iX v0.0.1 - [/size]

Offline vigilantez

  • Member
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: problems installing linux
« Reply #3 on: August 19, 2010, 10:46:59 PM »
i am currently using the latest version o ix and about the zImage i did have trouble but a friend did it for me but i will try again myself and the the full process again

adtionaly im using ubuntu 10.04 as a live USB to run ./oibc i have to run
sudo apt-get install libreadline5-dev
or else i get error

after the command !zImage i recivies the file
type in command kernel
i get
unknown command : kernel
i also get the same with ramdisk and boot

Offline wlt333

  • Member
  • Posts: 87
  • Karma: +0/-0
    • View Profile
Re: problems installing linux
« Reply #4 on: August 20, 2010, 02:08:26 AM »
Quote from: "vigilantez"
i am currently using the latest version o ix and about the zImage i did have trouble but a friend did it for me but i will try again myself and the the full process again

adtionaly im using ubuntu 10.04 as a live USB to run ./oibc i have to run
sudo apt-get install libreadline5-dev
or else i get error

after the command !zImage i recivies the file
type in command kernel
i get
unknown command : kernel
i also get the same with ramdisk and boot

I think your problem may be the openiboot.img3, oibc, or loadibec yuo are using to install.... are you using the newest of all those files?

Offline vigilantez

  • Member
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: problems installing linux
« Reply #5 on: August 20, 2010, 02:37:35 AM »
now i did it the way you posted it and still the same result unkown command: kernel

this time i installed VMware and installed ubuntu but still the same result idk what to try anymore :(

Offline vigilantez

  • Member
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: problems installing linux
« Reply #6 on: August 20, 2010, 02:58:13 AM »
Quote from: "wlt333"
I think your problem may be the openiboot.img3, oibc, or loadibec yuo are using to install.... are you using the newest of all those files?


when i turn on the iphone it says  openiboot 0.1.1 commit 5af5bc4 for iphone 3G

Offline Lopi

  • Moderator
  • Member
  • *****
  • Posts: 49
  • Karma: +0/-0
    • View Profile
Re: problems installing linux
« Reply #7 on: August 20, 2010, 03:15:23 PM »
Quote from: "vigilantez"
Quote from: "wlt333"
I think your problem may be the openiboot.img3, oibc, or loadibec yuo are using to install.... are you using the newest of all those files?


when i turn on the iphone it says  openiboot 0.1.1 commit 5af5bc4 for iphone 3G

You need a version of openiboot that supports complex openiboot console. You can download the latest version of OpeniBoot with iX support and complex oibc here:

http://dl.dropbox.com/u/8083946/openiboot.img3

Come to #iX on irc.osx86.hu if you need any help. I'm usually around.

Offline vigilantez

  • Member
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: problems installing linux
« Reply #8 on: August 20, 2010, 06:23:57 PM »
Quote from: "Lopi"
http://dl.dropbox.com/u/8083946/openiboot.img3

Come to #iX on irc.osx86.hu if you need any help. I'm usually around.


well now i passed those command errors but now after i use

boot "root=/dev/ram0 init=/init rw"

this happend
Code: [Select]
Booting kernel with arguments (root=/dev/ram0 init=/init rw)...
Proximity calibration data installed.
Multi-touch calibration data installed.
radio: reading baseband nvram... !���I�*** glibc detected *** ./oibc: double free or corruption (out): 0x09d35b28 ***
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6(+0x6b591)[0x3a6591]
/lib/tls/i686/cmov/libc.so.6(+0x6cde8)[0x3a7de8]
/lib/tls/i686/cmov/libc.so.6(cfree+0x6d)[0x3aaecd]
./oibc[0x80490ad]
/lib/tls/i686/cmov/libpthread.so.0(+0x596e)[0x6b696e]
/lib/tls/i686/cmov/libc.so.6(clone+0x5e)[0x408a4e]
======= Memory map: ========
Aborted

and linux goes thru the booting proces but doesnt boot  after it says

starting, please wait  
ixproject.org
james stubbs

cant open /sys/class/block/nand0p2/dev : no such file or directory

and not to many lines below
 The superblock could not be  read or does not discribe a correct ext2 filesystem


or try to get on irc once i have time becouse i just do this while im working  :)

Offline vigilantez

  • Member
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: problems installing linux
« Reply #9 on: August 21, 2010, 05:50:32 PM »
well i kept trying difrent things  and at the end i could get it to work  with a difrent kernel (idroid-fda0a53.EFI.nickpack.zip) the 1 supplied with ix just wouldnt work for my ipgone 3g

Offline Lopi

  • Moderator
  • Member
  • *****
  • Posts: 49
  • Karma: +0/-0
    • View Profile
Re: problems installing linux
« Reply #10 on: August 21, 2010, 11:00:36 PM »
Glad it's working for you now. Happy I could help you troubleshoot the issue.

Offline rathiopa

  • Member
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: problems installing linux
« Reply #11 on: August 24, 2010, 10:28:49 AM »
Thx for this topic. i had exactly the same problems on the 3G. After compiling the openiboot-loader from git-source on virtual ubuntu with ENABLE_EXTRA=YES PLATFORM=3G make openiboot.img3 ( http://www.idroidproject.org/wiki/Openi ... stallation ), i was able to boot with this image :-) But then, boot process also stopped with the kernel brought with the IX-Package. And i tried the kernel, told in this topic (http://idroid.nickpack.com/kernel/zImag ... ckpack.zip).. After that it worked :-) Thanks

Offline Phr³³k

  • Member
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: problems installing linux
« Reply #12 on: September 19, 2010, 08:39:32 PM »
i am stuck at the same error vigilantez first had.

i compiled openiboot.img3 version 1.1.2 commit c4341b7 but the kernel & ramdisk commands are still not recognized.
currently i don't know whats going wrong, can you please specify which openiboot version / commit includes the exetended command set need for iX?
still asked on irc but got no response, maybe time difference is to big :) i'm from germany.
the openiboot version for mojo 1.02 seems exactly the same when looking at version number & commit code, so whats going wrong here?

thanks for your reply.

cheers phk

Offline hedmo

  • Member
  • Posts: 17
  • Karma: +0/-0
  • iphone3g,ios3.1.3,ix-openiboot,ix,android 2.2.1
    • View Profile
Re: problems installing linux
« Reply #13 on: September 19, 2010, 10:20:15 PM »
its the opieniboot.img3 that cant make it
i am using ix-openiboot.img3
it makes it work but i am stuck with kernel panik (can not load some firmware)

Offline Phr³³k

  • Member
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: problems installing linux
« Reply #14 on: September 20, 2010, 04:00:59 PM »
yes it was the problem, missed out to compile oib with extras enabled.
now kernel & ramdisk command works but same error here:

stuck @ kernel panic and a bunch of errors before it.

init: rsyslog-kmsg main process killed by PIPE signal
init: rsyslog-kmsg main process ended, respawning
init: rsyslog main process killed by KILL signal
init: rsyslog main process ended, respawning
[   324.240000] Out of memory: kill process 153 (hald) score 1952 or a child
[   324.240000] Killed process 1079 (hald-runner)

Login timed out after 60 seconds.
init: tty1 main process ended, respawning
init: hal main process terminated with status 1
< some last logins mentioned >
[   383.940000] Kernel panic - not syncing: Attempted to kill init!

sounds like a 2g problem due to lack of memory? anyone with successful boot on iphone 2g here?