Talk:Installing iDroid (Linux)

From iDroid Project

Jump to: navigation, search

Successfully installed android on my iPhone 2G! :) Although, I'd like you to point some things out: During the openiboot installation, please make it more obvious that you actually need to put your phone in Recovery mode, not DFU mode, as your link on the words "Recovery mode" goes to a tutorial that tells you how to put your phone in DFU mode! Other than that, great job! I'm looking forward to future updates! --Sippeangelo 17:24, 25 April 2022 (UTC)


What exactly does provisioning do? I installed iDroid without it and it worked fine without. --Adrian 18:29, 25 April 2022 (UTC)

There is still reference to Windows on this page (I guess it's a copy-paste from the original page). This should be removed\moved. Since I do not completely understand the guide, I am not making those modifications myself - just wanted to raise the flag for someone to clean and edit this wiki page.

It has not been fully tested yet, but I have been working on porting to oibc to run with cygwin. Install, reboot, and uninstall all seem to be working. --Bricktwo4 14:20, 21 May 2022 (UTC)

I followed the entire howto with success, but I found a difference. My md5 hashes for the sd8686 files are different:

$ md5sum *bin | sort -k 2
3025de2a1ed575fd691958d7da341d8b  sd8686.bin
2a4d8f4df198ce949c350df5674f4ac6  sd8686_helper.bin
bad4dedccde0a5bef1a9468d918aa75a  zephyr_aspeed.bin
3c6f0f5f567a2a228aa290f2c49b583a  zephyr_main.bin

They remain the same for zephyr*.bin files.

Can it be elaborated a bit why FW 3.1.2 is used and not 3.1.3? I assume most iPhone 2G owners have upgraded to 3.1.3 (as they can both jailbreak and unlock), so this tutorial asks most users to downgrade, which is a hassle (especially for non-Mac owner without PwnageTool). Is there a real reason for this downgrade? can this be elaborated a little?-iphonebuff

The firmware file is only used to extract certain files not allowed to be included with the open source projects, (i.e. software copyrighted by apple), it doesn't actually affect your iPhone OS, just idroid/openiboot functionality. --Gomi No Sensei


Jailbreaking

I just completed this for my iPod Touch 1G using kernel at http://idroid.nickpack.com/kernel/zImage-alex/zImage-iPod1G_v0.3.rar but it took forever to actually get openiboot working. PwnageTool 3.1.5 and redsn0w 0.9.4 both didn't allow openiboot to be installed. Only the latest blackra1n worked. Dorsey 15:00, 23 June 2022 (UTC)